헤놀로지(Xpenology) 트랜스코딩 활성화하는방법.

profile
달소

 

안녕하세요. 달소입니다.

 

앞서 낙원전자 님께서 소개해주신 synocodectool-pacth에 대해 좀더 상세히 소개해드리고자 합니다.

 

트랜스코딩에 간단한 설명부터 헤놀로지에서 ssh를 활성화하고 트랜스코딩을 활성화하는 방법까지 모두 진행해보겠습니다.

 

트랜스코딩이 활성화되어있는지 확인하려면 아래 명령어로 확인해보시면 됩니다.

more /usr/syno/etc/codec/activation.conf

image.png.jpg

 

트랜스코딩이란?

트랜스코딩은 말그대로 재생하는 디바이스에서 영상의 코덱을 지원할지 못할때 실시간으로 인코딩을 하여 재생이  가능하도록 해주는것 입니다. 

예를 들자면 원본의 4k 영상을 디바이스에서 데이터 절약을 위해 fhd 혹은,hd로 변환할수있도록 도와줍니다.(plex h/w트랜스코딩)

대표적인건 인텔의 퀵싱크가 있고 j4105 등 내장그래픽이 있는모델에서 사용됩니다.

 

트랜스코딩의 효율의 경우 상당히 큰편이니 하드웨어가 지원한다면 꼭 적용하시는걸 추천드립니다.

 

  헤놀로지 or 기타 NAS를 사용하시는분들이 가장 많이 애용하시는 PLEX 입니다.   그리고 가장 많이들 궁금해하시는게 PLEX 에서 트랜스...
달소 | 2021.03.09

 

트랜스코딩 활성화하는방법

기본적으로 트랜스코딩의 경우 시놀로지 정품에서는 바로 될것이며

헤놀로지의 경우 인증받은 시리얼넘버(S/N) 과 기타 여러조건이 있으면 활성화 됩니다.

 

다만 시리얼넘버가 맞지않더라도 아래 깃허브의 스크립트를 통해 손쉽게 가능합니다.

*해당 트랜스코딩 활성화 스크립트는 기존 안정된 버전인 6.0 부터 최신버전의 7.0.1까지 지원합니다.

 

기본적인 요구사항은 아래와 같습니다.

 

  • DiskStation Manager 6 이상
  • 일련 번호는 올바른 형식이어야 합니다(예: DS918+의 경우 XXXXPDNXXXXXX, DS3617xs의 경우 XXXXODNXXXXXX, 3615xs의 경우 XXXXLWNXXXXXX).
  • x86-64 기반
  • SSH/터미널 액세스
  • sudo/루트

 

일련번호의 경우 DSM 제어판  -> 정보센터에서 확인가능합니다.

제 구형같은경우 DS918+ 인데 시리얼이 완전 예전꺼라서,, 이렇게되면 작동하지않으니 위 요구사항에 맞춰주세요.

image.png.jpg

 

 

이제 ssh를 활성화시켜주고 putty와같은 툴로 터미널로 접근해주세요.

제어판 -> 터미널 및 SNMP -> SSH 서비스 활성화

image.png.jpg

 

PuTTY로 헤놀로지 ip와 포트를 통해접속해주세요.
계정은 헤놀로지에서 사용하는 관리자계정으로 로그인해주시면됩니다.

 

image.png.jpg

 

로그인후에는 sudo su 명령어로 root권한으로 변경해주세요.

 

image.png.jpg

 

이제 스크립트를 다운로드 받고 실행권한을 주겠습니다.

 

wget https://raw.githubusercontent.com/Yanom1212/synocodectool-patch/master/patch.sh
chmod +x patch.sh

 

image.png.jpg

 

사용법은 아래와 같습니다.

 

# sudo ./patch.sh -h

SYNOPSIS
    patch.sh [-h] [-p|-r|-l]
DESCRIPTION
    Patch to enable transcoding without a valid serial in DSM 6+
     -h      Print this help message // help 명령어
        -p      Patch synocodectool // 패치하기.(패치할때 자동으로 백업합니다.)
        -r      Restore original from backup  // 문제가있을시 복구해줍니다.
        -l      List supported DSM versions // 지원 범위의 dsm 버전을 확인 할 수 있습니다.

 

최신버전인 7.0.1-42218-Update 2의 경우 아래댓글을 참고해주세요.

image.png.jpg

7.1의경우 7.1 42661-1 나 7.1 42661-2 로 넣어주시면됩니다.

 

위 사용법대로 진행하시면 큰 어려움은 없습니다.

바로 진행해보겠습니다.

 

sudo ./patch.sh -p

명령어를 입력하면 아래처럼 자동으로 버전을 확인해서 진행하며 바이너리 패치는 당연히 1번으로해주면됩니다.

image.png.jpg

 

이렇게 패치가 되면 activation.conf도 변경이 되는데 내용을 확인해보면 정상적으로 활성화 된것을 볼 수 있습니다.

more /usr/syno/etc/codec/activation.conf

 

image.png.jpg

 

원상복구방법은 -r 옵션을 주시면됩니다.

 

image.png.jpg

 

이제 트랜스코딩을 잘 활용해주시면됩니다!

이번에 7버전부터 추가된 얼굴인식도 트랜스코딩이 활성화 되어야 할수있기때문에 참좋은거같습니다.

서버포럼 관리자입니다.!

서버포럼은 홈서버로 운영중이며 아래와같은 시스템으로 운영됩니다.

 

메인서버 - Ryzen 5700G / Proxmox 7.2 / Ubuntu / Xpenology / 기타 VM 등등

보조서버 - Intel i9-9900ES(QQC0) / H370M / Proxmox 7.1 / 아직개발용서버로 사용중
백업서버 - 타오나스 A형(?) / DS918+ 6.2.3 / 메인서버 VM 백업용

 

하드웨어,가상화 등등 여러 IT분야에 관심이 두루두루많습니다만 깊게알고있는건 없습니다 하하하

 

 

적용중인 도장이 없습니다.

* 가입일 : 2020-12-24
* 총 게시글 수 : 6571
* 총 댓글 수 : 19932
* 추천받은 게시글 개수 : 2559
* 추천받은 댓글 개수 : 3201
Tag
댓글
75
  • 까치산개꿀탱<span class=Best" />
    2022.04.16

    7.1도 해결방법이 나오길 기대합니다 ㅎㅎ

  • quad
    레인99
    2022.08.26
    @quad 님에게 보내는 답글

    친절한 설명 감사합니다. 이제 이해했습니다.

     

    vi는 편집기이고 vi 상태에서 빠져나가질 못했던거네요 :q로 종료했습니다.

     

    종료전애 수정한 내용은

     

    ["796ac7fab2dcad7978a0e8ae48abc9150aba916c"]="7.1-42661-0_7.1-42661-0"

     

    ["22445f5b0d8b6714954b50930c47b8805cf32b98"]="7.1-42661-0_7.1-42661-0"

     

    으로 되어있던 것을

     

    ["796ac7fab2dcad7978a0e8ae48abc9150aba916c"]="7.1-42661-4_7.1-42661-4"

     

    ["22445f5b0d8b6714954b50930c47b8805cf32b98"]="7.1-42661-4_7.1-42661-4"

     

    로 바꾸어 저장했습니다만...

     

    저장 종료후에

     

    ash-4.4# sudo ./patch.sh -p

     

    Detected DSM version: 7.1 42661-4

     

    Patch for DSM Version (7.1 42661-4) not found.

     

    실패 한 것으로 나오네요.....

  • 레인99
    quad
    2022.08.26
    @레인99 님에게 보내는 답글

    지금 무엇을 하시려는 것인가요?

    어떤 장비로 어떤 모델에서 무엇이 안 되길래 이 페이지의 글을 읽고 뭔가를 해 보려고 하시는지요?

     

    순서대로 따라하기는 그걸 왜 하는지 이유를 알지 못 하면 조금만 삐끗해도 해결이 안 됩니다.

    그래서 물어 보는 것입니다.

     

    일단 편집을 잘 못 하신 것 같은데요?

     

    "6.2.3 25426-0"

    "6.2.3 25426-2"

    "6.2.3 25426-3"

    "7.0.1 42218-0"

    "7.0.1 42218-1"

    "7.0.1 42218-2"

    "7.0.1 42218-3"

    "7.1 42661-0"

    )

     

    #functions

    print_usage() {

    printf "

    SYNOPSIS

    patch.sh [-h] [-p|-r|-l]

    DESCRIPTION

    Patch to enable transcoding without a valid serial in DSM 6+

    -h Print this help message

    -p Patch synocodectool

    -r Restore from original from backup

    -l List supported DSM versions

     

    이 내용에서

    "7.1 42661-0"

    아래에

    "7.1 42661-4"

    를 넣어라는 것입니다.

    그게 없으니 위에 올리신 것 처럼 Patch for DSM Version (7.1 42661-4) not found. 가 나오는 것입니다. 7.1 42661-4가 없다고 써 있잖아요.

     

    1. vi patch.sh

    2. i

    3. "7.1 42661-0" 아래에 "7.1 42661-4" 입력

    4. ESC 누름

    5. :wq! 엔터

     

    그 다음 sudo ./patch.sh -p 하면 됩니다.

  • quad
    레인99
    2022.08.26
    @quad 님에게 보내는 답글

    이해했습니다.

    수정이라해서 해쉬값(?)옆에 있는 7.1 42661-0을 7.1 42661-4로 수정했는데, 그게 아니었고 그곳에 추가하는 거였네요.

  • 레인99
    quad
    2022.08.26
    @레인99 님에게 보내는 답글

    처음부터 가 보지요.

     

    지금 무엇을 하시려는 것인가요?

    어떤 장비로 어떤 모델에서 무엇이 안 되길래 이 페이지의 글을 읽고 뭔가를 해 보려고 하시는지요?

  • quad
    quad
    2022.08.26
    @quad 님에게 보내는 답글

    이해해도 별로 소용이 없을겁니다.

    아직도 무슨 장비로 뭘 하시려는 건지 대답하시지 않는군요.

    그러니 전체적인 구조와 지금 하시는 것의 의미등 큰 그림을 이야기 해 드릴 수가 없네요.

  • quad
    레인99
    2022.08.26
    @quad 님에게 보내는 답글

    아 댓글이 늦었습니다. 헤놀로지 920 dsm 7.1 42661-4에 AME 패키지 설치하려는 중입니다.

  • 레인99
    quad
    2022.08.26
    @레인99 님에게 보내는 답글

    코덱은 있으신가요?

    지금 하시는 작업은 코덱은 확보해 놓았는데, 시놀로지의 정품 시리얼이 없을 때, 정품 시리얼이 없어도 코덱이 작동하게 해 주는 패치입니다.

  • quad
    레인99
    2022.08.26
    @quad 님에게 보내는 답글

    arpl에서 자동으로 만든 시리얼입니다.

    코덱을 확보해두라는 글을 못봤습니다. 내가 너무 건너 뛴 모양이군요.

     

     

     

  • quad
    희라
    2022.08.26
    @quad 님에게 보내는 답글

    혹시 코덱은 패키지 센터에서 ffmpeg만 설치하면 될까요?

     

    저는 DSM6.2에서 FFMPEG를 설치한 상태로 바로 이 패치를 하니 정상동작 하더라구요

  • 희라
    quad
    2022.08.26
    @희라 님에게 보내는 답글

    7.1부터 바뀌었습니다.

    https://svrforum.com/nas/400007

    이글을 정독하세요.

  • quad
    희라
    2022.08.28
    @quad 님에게 보내는 답글

    아 제가 댓글뜻을 잘못 작성했네요

     

    6.2에서 ffmpeg를 설치한후 7.1로 업데이트,ㅁ ffmpeg업데이트 후 이 게시물을 적용하니 트랜스코딩이 가능하더라구요!

    테스트는 비디오스테이션에서 재생품질을 원본,높음,낮음으로 할시 정상적으로 화질이 낮게 재생되었습니다!

  • quad
    레인99
    2022.08.28
    @quad 님에게 보내는 답글

     

    정보, 도움 감사드립니다.

     

    Spoofed activation.conf created successfully

    ash-4.4# more /usr/syno/etc/codec/activation.conf

    {"success":true,"activated_codec":["hevc_dec","ac3_dec","h264_dec","h264_enc","a

    ac_dec","aac_enc","mpeg4part2_dec","vc1_dec","vc1_enc"],"token":"123456789987654

    abc"}

    ash-4.4#

     

    드디어 성공한 것이지요?

     

    vi 편집기에서 추가시키는 부분을 못 찾아 엉뚱한 곳에 추가한 것이 원인이었던 것 같습니다.

     

    코덱은 7.0부터 사용하던 것이라 내장되어있었던 것 같네요.

    그러면 패치할 필요도 없었던 것일까요?

    패치전에도 시놀 포토스에서 아이폰으로 찍은 HEIC사진과 HEVC동영상도 잘 보였으니까요.

     

    포토스에서는 잘 보이지만 비디오 스테이션에서 여전히 지원되지 않는 형식이니 HME로 이동해서 시놀로지 로그인하고 코덱팩을 설치하라는 문구가 나와 재생 안되는건 어쩔 수 없는 부분인가봅니다?...

    아니면 아직 무언가 잘 안된 것인지요?

    비디오 스테이션은 사용하지 않으니 상관이 없긴 합니다만...

     

    도스 시절부터 사용했었는데 리눅스는 사용할 일이 없었으니 영 생소합니다.

  • 레인99
    quad
    2022.08.31
    @레인99 님에게 보내는 답글

    "코덱은 7.0부터 사용하던 것이라 내장되어있었던 것 같네요"

    -> 내장되어 있지 않을텐데요? 7.1설치는 7.0위에 설치하는것이 아니라 7.0을 싹 밀어버리고 설치를 하는 것이고, 7.1에는 코덱이 없습니다.

     

    "패치전에도 시놀 포토스에서 아이폰으로 찍은 HEIC사진과 HEVC동영상도 잘 보였으니까요"

    -> 이 패치 전은 7.0떄인가요? 아니면 7.1로 올리고 패치하기 전인가요?

  • quad
    레인99
    2022.08.31
    @quad 님에게 보내는 답글

    7.1로 올리고 패치전 입니다.

  • foranie
    2022.08.29

    vi는 학교서만 쓰던거라.. 포기하고 nano를 쳤더니.. 없네요

    그냥 patch가 받아지는 경로가 로그인 계정의 루트라 그냥 네트워크 폴더로 \\nas\homes\mylocalauthid\patch.sh로 접근해 vc로 수정했습니다. 42661-4

댓글 쓰기
권한이 없습니다.