이게 뭔 일인가요?

테돌아이

백업을 하다가  중단하니 이런 현상이 생기네요 ㅠㅠ

 

Task viewer: VM 100 - Start

OutputStatus

Stop

no efidisk configured! Using temporary efivars disk.
TASK ERROR: unable to activate storage 'Backup_Data' - directory is expected to be a mount point but is not mounted: '/mnt/pve/Backup_Data'

 

vm 밑 스토리지가 있는 부분에 "?" 가 나옵니다.

이것 어떻게 살릴수 있을까요?

구글검색을 하니 스토리지id 뭐 어쩌구 하는데 스토리지id는 어디에서 볼 수 있나요?

매번 질문폭주네요 ㅠ

감사합니다. 

댓글
10
  • 달소
    2022.08.09

    에러로그상태를 천천히 보시면 답이 다 나와있습니다.

    TASK ERROR: unable to activate storage 'Backup_Data' - directory is expected to be a mount point but is not mounted: '/mnt/pve/Backup_Data'

     

    Backup_Data 스토리지에 접근을 할수없다고 나오고 마운트가 제대로 안된거같다고하네요. ?로 나오는것 역시 해당 스토리지 오류입니다.

  • 달소
    테돌아이
    작성자
    2022.08.09
    @달소 님에게 보내는 답글

    답글 감사합니다.

    마운트가 제대로 안된건 알겠는데 이것을 어떻게 해결할 수 있는지요 ㅜ

  • 테돌아이
    달소
    2022.08.09
    @테돌아이 님에게 보내는 답글

    음.. 하나씩 살펴보셔야할것같은데요. 스토리지에 제대로 등록은 되어있는지 사용체크는 되어있는지 등등이요

  • 달소
    테돌아이
    작성자
    2022.08.09
    @달소 님에게 보내는 답글

    웹상에서는 모두가 정상적으로 설정이 되어 있습니다.

     

    /etc/pve/storage.cfg 내용에 다음과 같이 정의되어 있고요.

     

    dir: local

    path /var/lib/vz

    content vztmpl,iso,backup

     

    lvmthin: local-lvm

    thinpool data

    vgname pve

    content rootdir,images

     

    dir: Backup_Data

    path /mnt/pve/Backup_Data

    content snippets,vztmpl,rootdir,backup,iso,images

    is_mountpoint 1

    nodes dell

    shared 0

  • 달소
    테돌아이
    @달소 님에게 보내는 답글

    2.PNG.jpg

    이런 현태입니다.

  • 테돌아이
    달소
    2022.08.09
    @테돌아이 님에게 보내는 답글

    해당 path 경로에 어떤 디스크를 어떻게 마운트하신거죠?

    마운트는 정상적으로 된건가요?

     

    질문을 주시는 의도는 전달이 되나 내용전달이 전혀되지않습니다.

     

    해당 디스크 구성이어떻게 되어있는지 스토리지 구성은 어떻게되어있는지. 마운트는 어떻게하신건지 어떤 파티션인지 내용적인 부분은 하나도 주시지않고 단순하게 설정 스크린샷만 올려주신다면 도움을 드릴 수 있는 방법이없습니다.

     

    질문을 주신입장에서 보았을때는 그걸로 충분하시다고 보실수도있지만 답변을 드리는 입장에서는 전후 상황을 모르는상태에서 는 어떤답을 드리던 정답이 되기는 힘듭니다.

     

    불필요하다고 생각되는 정보들을 모두 주셔야 답변을 달아드리는분이 그걸 조합해서 답변을 드리는것이지 댓글로 이것 여쭤보고 저것 여쭤보고 티키타카하는건 서로에게 좋지않은 방법이라고생각합니다

  • 달소
    테돌아이
    작성자
    2022.08.09
    @달소 님에게 보내는 답글

    답변감사합니다.

     

    parted /dev/sde "mklabel apt" 실행

    Disks/Directory 선택

    Create:Directory

    disk: /dev/sde1

    filesystem : ext4

    Name: Backup_Data

    이렇게 하고 백업전용으로 사용하고 있었습니다.

    이게 끝입니다.

  • 달소
    테돌아이
    작성자
    2022.08.09
    @달소 님에게 보내는 답글

    만약 이것을 삭제하고 다시 위 방법대로 만들면 기존에 있는 백업파일들이 모두 날아가겠죠? ㅠ

    백업과 ios 파일들만 있기 때문에 날아가도 되는데 최대한 기존 셋팅한 백업을 살리고자 ㅠ

  • 테돌아이
    테돌아이
    작성자
    2022.08.09
    @테돌아이 님에게 보내는 답글

    헐...

    Disks/Directory 선택

     

    Create:Directory

     

    disk: /dev/sde1

     

    filesystem : ext4

     

    Name: Backup_Data

    이것을 지우고 다시 설정하니 초기화가 되어버리네요

    좋은 경험을 했다고 생각을 하겠습니다.

    근데 이런 현상이 왜 일어나는지 몰라 아쉽네요. ㅠ

  • 달소
    테돌아이
    작성자
    2022.08.09
    @달소 님에게 보내는 답글

    이러한 현상을 다시 제연을 했습니다.

    백업서버가 아니라 vm 백업을 선택해서 백업을 하다가 중단을 시키니 중단을 해도 계속 백업모드이고 잠김상태더라고요.

    그래서 서버를 재부팅을 했는데 vm을 시작을 하지 못하더라고요

    그래서 관련디스크를 모두 제거하고 vm은 부팅을 했습니다.

    그런데 백업디스크가 그렇게 되어 있더라고요.

    처음부터 서버 재부팅을 하지 않고

    qm unlock 101

    명령을 실행하니 모든게 정상적으로 돌아오네요. ㅠㅠ

     

댓글 쓰기
권한이 없습니다.